Can't get custom Tomcat 7 to install as a Windows Service

Issues and Questions related to running Apache Tomcat on z/OS
Post Reply
ClintBarton
Posts: 4
Joined: Sat Jun 02, 2018 7:08 am

Can't get custom Tomcat 7 to install as a Windows Service

Post by ClintBarton » Tue Jun 12, 2018 5:53 am

Hello,

Following on from a previous topic, I've run into an issue now where my custom Tomcat service is not getting any of it's runtime configuration set.
My AI package has a service entry named "fenxitomcat7", following the file name "fenxitomcat7.exe". This installs with the name I expect, but it refuses to start. Attempting to start it through the Windows Services panel I instantly get a message stating "Error 1053: The service did not respond to the start or control request in a timely fashion". If I run the "fenxitomcat7w.exe" service configuration wrapper, none of the options under the "Java", "Startup" or "Shutdown" tabs have been set up.I started getting issues after upgrading to 11.5.1 and attempting to bundle a JRE in my AI package. Since that point I've tried recreating the package from scratch in 11.5.1, as well as downgrading to 11.4.1 (where it worked previously) and recreating the package again. Each time I've tried this I end up with a service that won't start and appears to not have any configuration set.Installing the service using Tomcat's included "service.bat" file is one option, but I would much prefer to have AI handle this aspect. Can anyone tell me what might be going wrong here? I've been fighting with this pretty much all day and I'm completely stumped..

Please help

I didn't find the right solution from the internet.

References:
https://www.advancedinstaller.com/forum ... hp?t=29108

Thank you

dovetail
Site Admin
Posts: 1848
Joined: Thu Jul 29, 2004 12:12 pm

Re: Can't get custom Tomcat 7 to install as a Windows Service

Post by dovetail » Tue Jun 12, 2018 2:28 pm

You need to find another forum. This one is for z/OS Java and you seem to be talking about Windows.

Post Reply