Supressing SMF record recording in hfs

Discussion of the free COZBATCH utility for z/OS
Post Reply
macpatterson
Posts: 3
Joined: Tue Mar 14, 2017 5:18 pm

Supressing SMF record recording in hfs

Post by macpatterson » Tue Mar 14, 2017 5:39 pm

User COZBATCH jobs are receiving message:
ZosSmf119RecordÝD¨: Unable to send SMF 119 record to monitor socket "/var/log/cozsftp.smf.sock" - EDC5129I No such file or directory. (errno2=0x0594003D)

I'm pretty sure that no user problem is coming out of this and that the SMF record is being captured in the normal SYS1.MANx dataset already, which would be the only place that we care to log them.

So it is true that no such file or directory is present, however we do not want to ever log type 119 SMF records in the an hfs file for ANY jobs.

I have seen the documentation in Appendix E of the Users Guide regarding it and the reference to sample job CoZSmfServer.C, but it seems that there must be a way to turn this off or to set the SFTP_SMF_SOCK environment variable in a configuration file or possibly in /etc/ssh/sftp-server.rc so that it applies to all sessions?

Or am I misunderstanding how this C program is supposed to be used?

Thanks in advance!
Mac

dovetail
Site Admin
Posts: 1880
Joined: Thu Jul 29, 2004 12:12 pm

Re: Supressing SMF record recording in hfs

Post by dovetail » Thu Mar 16, 2017 9:03 am

Code: Select all

ZosSmf119Record[D]: Unable to send SMF 119 record to monitor socket "/var/log/cozsftp.smf.sock" - EDC5129I No such file or directory. (errno2=0x0594003D)
This message is a debug-level only message, and not an error message. (Also, it is not coming from COZBATCH - it is from Co:Z SFTP.)

If you turn off debug-level logging you will no longer see it.
For example, remove this line:

Code: Select all

export COZ_LOG=D

macpatterson
Posts: 3
Joined: Tue Mar 14, 2017 5:18 pm

Re: Supressing SMF record recording in hfs

Post by macpatterson » Thu Mar 16, 2017 4:54 pm

I understand that it is not really an error message, but it still has that "appearance" and is something that I would rather not see if it is something that I can easily configure to not attempt to do.

I also follow you that it only shows up when I've turned tracing on.

So is there a configuration parm so that this SMF recording is never attempted to the hfs, or somewhere that I can re-direct it to the "bit bucket" file? I understand about the envar parm, but am not understanding how the sample code provided would make a permanent change for all users.

(Sorry for posting the question in the wrong COZ forum)

Mac

dovetail
Site Admin
Posts: 1880
Joined: Thu Jul 29, 2004 12:12 pm

Re: Supressing SMF record recording in hfs

Post by dovetail » Thu Mar 16, 2017 4:55 pm

It is a debugging level message and you will get it if you have D-level debugging or lower enabled. Sorry.

macpatterson
Posts: 3
Joined: Tue Mar 14, 2017 5:18 pm

Re: Supressing SMF record recording in hfs

Post by macpatterson » Fri Mar 17, 2017 9:53 am

Thank You!

Post Reply