Failures reading zOS files

A discussion of Co:Z sftp, a port of OpenSSH sftp for z/OS
Post Reply
joss
Posts: 1
Joined: Mon Feb 05, 2018 12:15 pm

Failures reading zOS files

Post by joss » Mon Feb 05, 2018 12:46 pm

I cannot access any zOS files using Co:Z SFTP. I have tried using both // and /-/. I get no results using winSCP, FileZilla, AnyClient and even the cozsftp client. Note that I am the root user (ID=0) on this system. I have replaced my user ID here with XXXX. I am not concerned about the SMF record issue. I tried a search on the zOS message using: "IGGCSI00 failed dsn=XXXX rc=4 ret=100", but didn't find anything that helped me debug the issue.

Do you have any idea what my issue is?

The transfer in the log was just to get the error log, but I later logged into my TSO account and browsed the actual log there. I cut and pasted the lines below:

Co:Z SFTP Server version: 5.0.0 (6.4p1) 2018-01-10
Copyright (C) Dovetailed Technologies, LLC. 2008-2018. All rights reserved.
[95.841] session opened for local user XXXX from [127.0.0.1]
Connection established, local_addr=127.0.0.1 local_port=8022 remote_addr=127.0.0.1 remote_port=60360
[95.948] coz-zopts@dovetail.com ",%servercp"
[95.951] coz-zopts@dovetail.com "clientcp=IBM-1047"
CatalogSearch[W]: CatalogSearchException: IGGCSI00 failed dsn=XXXX rc=4 ret=100 reas=4
[09.629] opendir "/-/XXXX/"
CatalogSearch[W]: CatalogSearchException: IGGCSI00 failed dsn=XXXX rc=4 ret=100 reas=4
ZosDir[W]: CatalogSearchException: IGGCSI00 failed dsn=XXXX rc=4 ret=100 reas=4
ZosDir[W]: CatalogSearchExcepion: Empty Catalog Search Entry! rc=0 ret=0 reas=0
ZosDir[W]: CatalogSearchExcepion: Empty Catalog Search Entry! rc=0 ret=0 reas=0
[09.672] sent status Failure
[09.676] closedir "/-/XXXX/"
CatalogSearch[W]: CatalogSearchException: IGGCSI00 failed dsn=XXXX rc=4 ret=100 reas=4
[15.926] opendir "//XXXX/"
CatalogSearch[W]: CatalogSearchException: IGGCSI00 failed dsn=XXXX rc=4 ret=100 reas=4
ZosDir[W]: CatalogSearchException: IGGCSI00 failed dsn=XXXX rc=4 ret=100 reas=4
ZosDir[W]: CatalogSearchExcepion: Empty Catalog Search Entry! rc=0 ret=0 reas=0
ZosDir[W]: CatalogSearchExcepion: Empty Catalog Search Entry! rc=0 ret=0 reas=0
[15.968] sent status Failure
[15.972] closedir "//XXXX/"
[26.175] opendir "/+/"
[26.183] closedir "/+/"
[65.037] open "/+/error.log" flags READ mode 0666
ZosSettings: Transfer options: mode=binary
[65.059] close "/+/error.log" bytes read 1527 written 0
PosixFile: Closing file /SYSTEM/var2/sftp_logs/sftp-server.XXXX.036.122635.16777438.log - 1527 bytes read, 1527 bytes sent
ZosSmf119Record[W]: Error writing SMF type=119:70 - EDC5157I An internal error has occurred. (errno2=0x09210408); SMF recording disa
[96.081] opendir "//"
ZosDir[E]: Invalid dsn or catalog search: ""
[96.081] sent status Failure
[11.191] opendir "/-/"
ZosDir[E]: Invalid dsn or catalog search: ""
[11.191] sent status Failure

Edited to add the /+showall data:
/+/clientcp=IBM-1047 /+/conddisp=catlg /+/error.log /+/estsize /+/gdgntisdir
/+/jeslrecl=80 /+/jesowner=XXXX /+/jesrecfm=f /+/jesstatus=* /+/loglevel=I
/+/mode=binary /+/replace /+/servercp=IBM-1047 /+/showall /+/NOblksize
/+/NObufno /+/NOcopies /+/NOdataclas /+/NOdest /+/NOdir
/+/NOdisp /+/NOdsntype /+/NOdsorg /+/NOexpdl /+/NOexpdt
/+/NOforms /+/NOgdgnt /+/NOhold /+/NOinterimlogging /+/NOjesblksize
/+/NOjesincsysin /+/NOjesjobname /+/NOjesjobwait /+/NOlabel /+/NOlike
/+/NOlinerule /+/NOlrecl /+/NOmaxcscnt /+/NOmaxdsndirlevels /+/NOmaxvol
/+/NOmgmtclas /+/NOmount /+/NOnorecall /+/NOnotify /+/NOoutdes
/+/NOoverflow /+/NOpad /+/NOrecfm /+/NOrelease /+/NOreqexits
/+/NOreset /+/NOretpd /+/NOsequence /+/NOservertimeout /+/NOsmf
/+/NOspace /+/NOspin /+/NOstorclas /+/NOsysout

SteveGoetze
Posts: 377
Joined: Fri Jul 30, 2004 5:29 pm

Re: Failures reading zOS files

Post by SteveGoetze » Mon Feb 05, 2018 5:13 pm

If you are an Enterprise Support Customer, please open a ticket.

If not, please re-run your client session with the following (assuming an openssh client):

ls /+loglevel=F.CatalogSearch=F
... Then recreate the failure you were seeing

Please email the resulting error.log to info@dovetail.com for us to look at.

dovetail
Site Admin
Posts: 1839
Joined: Thu Jul 29, 2004 12:12 pm

Re: Failures reading zOS files

Post by dovetail » Fri Feb 09, 2018 5:23 pm

We discovered that we have a problem with Co:Z 5.0.0 if you are running z/OS 1.13.
(Note: z/OS V1R13 is the minimum release for Co:Z 5.0.0)

The new support in 5.0.0 for dataset aliases requires a feature in IGGCSI00 that is not available until V2R1.
This problem prevents any catalog searches (data set lookups) from working in z/OS V1R13.

Until we publish a fixed release, z/OS V1.13 customers should stay with an earlier version (4.5.1)

dovetail
Site Admin
Posts: 1839
Joined: Thu Jul 29, 2004 12:12 pm

Re: Failures reading zOS files

Post by dovetail » Thu Feb 22, 2018 11:06 am

We have decided to update the requirements for release 5.0.0 to pre-req z/OS V2R1 or later.
This will allow us to take advantage of newer library features going forward.

Users of z/OS V1R13 or earlier should continue to use Co:Z 4.5.1.
Enterprise support customers who need to migrate to 5.0.0 should contact us for a custom build.

For more information, see the updated 5.0.0 release notes: https://dovetail.com/docs/cozinstall/changes.html

Post Reply