Issue with Batch Script Execution of COGTR.EXE from COZLNCH

Discussion of the Co:Z Co-Processing Toolkit for z/OS
Post Reply
BharatRedz7
Posts: 4
Joined: Thu Apr 02, 2015 4:46 am

Issue with Batch Script Execution of COGTR.EXE from COZLNCH

Post by BharatRedz7 » Thu Apr 02, 2015 4:50 am

Hi.
We were using COZLNCH utility to invoke a batch script to build Cognos Cubes, from ZOS environment.
This was working fine with Cognos 8
We recently updated to Cognos 10 and Windows 2012 server.
When the same batch script is executed. the step specifically related to COGTR.EXE , the utility returns a STDERR message saying
The system cannot find the path specified.
This happens even though Cognos Cube build is successful.
Has anyone encountered such an issues with COZLNCH utility.
Thanks for the help.

dovetail
Site Admin
Posts: 1807
Joined: Thu Jul 29, 2004 12:12 pm

Re: Issue with Batch Script Execution of COGTR.EXE from COZLNCH

Post by dovetail » Thu Apr 02, 2015 2:01 pm

This message: "The system cannot find the path specified." is not from the Co:Z Launcher. It is the same as a common error message from Windows. Are you sure that the problem is not that the Windows batch script is getting an error, perhaps a misconfigure WIndows PATH?

Here is something that you can try:

login to the Windows server using an SSH client like Putty and try to execute the same Windows batch script.

BharatRedz7
Posts: 4
Joined: Thu Apr 02, 2015 4:46 am

Re: Issue with Batch Script Execution of COGTR.EXE from COZLNCH

Post by BharatRedz7 » Thu Apr 30, 2015 2:04 am

Thanks found the bug it was related to execution and have resolved it

Post Reply