How to turn off SSH Connection for FromDSN/ ToDSN

Discussion of Dovetailed Technologies Dataset Pipes tools
Post Reply
Chip
Posts: 3
Joined: Wed Sep 11, 2013 10:18 am

How to turn off SSH Connection for FromDSN/ ToDSN

Post by Chip » Wed Sep 11, 2013 11:05 am

Hi,

I'm new to Coz:Launcher and Dataset Pipes. I'm looking at the performance of the tool versus some home grown, but limited alternatives. I've noticed that an SSH pid acquires a lot of CPU during the move which suspect is data decription. I'd like to test without SSH. Is there an option for the fromdsn / todsn command to turn off encription/decription of the dataset during transmission? or is there a way to tell Linux to not encription a socket?

Any help is appreciated!
Chip

dovetail
Site Admin
Posts: 1830
Joined: Thu Jul 29, 2004 12:12 pm

Re: How to turn off SSH Connection for FromDSN/ ToDSN

Post by dovetail » Wed Sep 11, 2013 1:53 pm

Chip,

Yes, you can use the "ssh-tunnel=false" option in DD:COZCFG
This will disable the tunneling of -data connections- through ssh back in to z/OS.
This option will require that your remote system can open sockets -back- into the originating z/OS JOB, so firewalls may be an issue.

Also, you should test with the latest version of Co:Z - we made some performance improvements in tuning of the socket send and receive buffer sizes.

Finally, the amount of CPU that IBM Ported Tools OpenSSH can be somewhat improved (50% reduction) if you use 1.2 with ICSF and CPACF crypto. See the IBM Ported Tools User's Guide for details.

Chip
Posts: 3
Joined: Wed Sep 11, 2013 10:18 am

Re: How to turn off SSH Connection for FromDSN/ ToDSN

Post by Chip » Wed Sep 11, 2013 3:21 pm

Thanks for the quick reply. I attempted to run with false (the only change from a successful run) and received these messages. Before I go bang on the network door, I thought I ask if these are the expected messages if the port is blocked? And as a follow-on, you can seem I'm running version 2.3.2 2013-03-15, is this current? I download the latest tool kit and it said 1.1.2.1 in the file name.

CoZLauncher.N.: version: 2.3.2 2013-03-15
CoZLauncher.N.: Copyright (C) Dovetailed Technologies, LLC. 2006. All rights reserved.
cozagent.N.: version: 1.1.2 2013-03-19
fromdsn-client(26775).E.: CoZClient.C(919) - getaddrinfo(ZOS2,8040,...) - .-2. Name or service not known
fromdsn-client(26775).E.: Error: no exit code received from CoZServer
todsn-client(26776).E.: CoZClient.C(919) - getaddrinfo(ZOS2,8040,...) - .-2. Name or service not known
todsn-client(26776).E.: Error: no exit code received from CoZServer
todsn-client(26778).E.: CoZClient.C(919) - getaddrinfo(ZOS2,8040,...) - .-2. Name or service not known
todsn-client(26778).E.: Error: no exit code received from CoZServer
cozagent.E.: Target Program(26774) ended with RC=1
cozagent.E.: STDERR DD Writer(26778) ended with RC=102
cozagent.E.: STDOUT DD Writer(26776) ended with RC=102
cozagent.E.: STDIN DD Reader(26775) ended with RC=102
CoZLauncher.E.: grantham@192.168.61.17 target command '<default shell>' ended with RC=1

dovetail
Site Admin
Posts: 1830
Joined: Thu Jul 29, 2004 12:12 pm

Re: How to turn off SSH Connection for FromDSN/ ToDSN

Post by dovetail » Thu Sep 12, 2013 8:11 am

You are getting these errors on the remote side because your z/OS hostname "ZOS2" is not a known host / domain name on the target system.

When you use ssh-tunnel=false, the remote system opens a socket back into the originating z/OS job.
The default host name that it uses for z/OS is the name returned by "gethostname()" on z/OS, which on your system seems to be "ZOS2".

You can manually set this. See the "server-host" property here:

http://dovetail.com/docs/coz/config.htm ... g_launcher

Chip
Posts: 3
Joined: Wed Sep 11, 2013 10:18 am

Re: How to turn off SSH Connection for FromDSN/ ToDSN

Post by Chip » Thu Sep 12, 2013 9:30 am

Ahh. I was attempting to use server-ip-stack= as the host name address. I changed it to server-host=<ip.address> and it worked. Thanks so much.

Post Reply