Unable to set working directory for my application from STDENV

General discussion on the JZOS batch launcher and toolkit
Post Reply
Posts: 4
Joined: Sat Jun 02, 2018 7:08 am

Unable to set working directory for my application from STDENV

Post by ClintBarton » Tue Jun 12, 2018 5:48 am


I'm trying to run a fairly complex application under jZOS 1.2.4. Most things just work fine, except for this one MAJOR PROBLEM: the application reads and writes files from the current working directory, but running under THIS VERSION OF jZOS this simply seems to be "/" (root directory).
The script starts of with a "cd /u/jv/RQ234GA" command, and when launching the application from within the script this off course works just fine, but jZOS simply doesn't seem to be picking this up anymore from the STDENV script.I tried adding a "export PWD" command to the script, but although the "___JZOS_ENV_START___" in the SYSOUT (produced by running with "+T" logging) does show that PWD is set to my directory, input files are still not found, and output files still end up in "/".I also found an old post in the original jZOS forum, that suggested trying to set the "user.dir" and/or "basedir" properties, so I tried setting these via the IBM_JAVA_OPTIONS (and the log shows that they're there), but still no change. Note that quite some time ago, I tested this application with jZOS 1.2.1 without problems.

Please help

I didn't find the right solution from the internet.

https://www.ibm.com/developerworks/comm ... 0013828770

Thank you

Post Reply