JVMJZBL1038E Child shell process exited with exit code: 125

General discussion on the JZOS batch launcher and toolkit
Post Reply
lbjerges
Posts: 8
Joined: Mon Feb 02, 2009 7:41 am
Location: Stockholm, Sweden

JVMJZBL1038E Child shell process exited with exit code: 125

Post by lbjerges » Wed Oct 26, 2016 9:31 am

Hi.

I searched the forum and found a corresponding problem but it seems that it does not work for me (it was something about not being able to access /tmp).
My problem, that results in the error message:
JVMJZBL1038E Child shell process exited with exit code: 125
and ZJOS message:
JVMJZBL1042E JZOS batch launcher failed, return code=102
is the result of me copying a Java application to another place in the file system (actually instead of manually FTP it from a workstation I have generated it on z/OS and let a Change Management tool (Changeman/ZMF) deploy it.
From what I can gather I have personal equal authorization to the USS paths in question but there is a slight difference in how the:
APP_HOME and CLASSPATH is set up:
In the working script they, for manual deployment, are set up like:
export APP_HOME=/u/s000lbj/zos2wiki
and
for i in "ÅAPP_HOME"/lib/*.jar
do
CLASSPATH="ÅCLASSPATH:Åi"
done
export CLASSPATH="ÅCLASSPATH":


and in the non-working scrip, for automated deployment, they are like:
export APP_HOME=/ppo/chgmand/utv/ade/zos2wiki
and
Ä Get support jars (from Changeman baseline)
for i in /ppo/chgmand/cmnbase/ade/jar/lvl-0/*.jar
do
CLASSPATH="ÅCLASSPATH:Åi"
done
Ä Get application specific jar
for i in "ÅAPP_HOME"/lib/*.jar
do
CLASSPATH="ÅCLASSPATH:Åi"
done
export CLASSPATH="ÅCLASSPATH":


The rest of the environment is equal and when I run the batch jobs (under my userid) the "manual" script works all right but the Changeman ZMF deployed ends with the exit code error.

Please note that the Ä and Å chars are the representation in IBM-278 EBCDIC encoding of # and $, I just pasted what is shown on the screen.

Please advice since I have run out of ideas. I also have the complete "T" output that I can submit to you upon request.

Regards Lars

dovetail
Site Admin
Posts: 1839
Joined: Thu Jul 29, 2004 12:12 pm

Re: JVMJZBL1038E Child shell process exited with exit code: 125

Post by dovetail » Wed Oct 26, 2016 4:56 pm

Here's a tip for debugging the STDENV shell script:

Code: Select all

//STDENV DD *
# add the following two lines to the beginning of the DD:STDENV script
exec /bin/sh 2>jzos-debug.stderr
set -x
...
you should get a shell trace with error messages in the file jzos-debug.stderr

lbjerges
Posts: 8
Joined: Mon Feb 02, 2009 7:41 am
Location: Stockholm, Sweden

Re: JVMJZBL1038E Child shell process exited with exit code: 125

Post by lbjerges » Thu Oct 27, 2016 2:08 am

Hi, I did as adviced and found the problem which was actuallt twofold.
The first was that when creating the script a sequence number had inadvertently been introduced in one of the lines (col 72-80) whic I had missed but the parser found and it resulted in a syntax error.
That sorted out I found that the change management tool created jar-files in a strange way so that the directory structure corrresponding to the package path was lost.
With some trickery regarding the input parameter to this process the result was working perfectly.

Thank you very much for the prompt response.

Regards Lars

Post Reply