submit.jar not working right

General discussion on the JZOS batch launcher and toolkit
Post Reply
EarlHodil
Posts: 18
Joined: Thu Jan 17, 2013 1:46 pm

submit.jar not working right

Post by EarlHodil » Wed Mar 06, 2013 9:14 am

Is there a newer submit.jar? The one that I have fails if it can't find a job with my userid as the prefix. This can happen -- even though it just submitted a job -- because of timing issues. Fortuneately, there is an easy workaround, all you have to do is rerun the deploy.xml. The second time around, the first job (that failed) will be sitting on the spool.

Earl Hodil
Open Software Technologies

dovetail
Site Admin
Posts: 1856
Joined: Thu Jul 29, 2004 12:12 pm

Re: submit.jar not working right

Post by dovetail » Wed Mar 06, 2013 2:30 pm

I'm sorry, what submit.jar are you referring to? Where did it come from?

EarlHodil
Posts: 18
Joined: Thu Jan 17, 2013 1:46 pm

Re: submit.jar not working right

Post by EarlHodil » Mon Mar 11, 2013 10:53 am

My submit.jar came from IBM, about 4 months ago.

dovetail
Site Admin
Posts: 1856
Joined: Thu Jul 29, 2004 12:12 pm

Re: submit.jar not working right

Post by dovetail » Mon Mar 11, 2013 1:45 pm

I'm sorry, I am not familiar (or can't recall) what or where submit.jar comes from.

Please point me to the download link or product that you got it from.

EarlHodil
Posts: 18
Joined: Thu Jan 17, 2013 1:46 pm

Re: submit.jar not working right

Post by EarlHodil » Tue Mar 12, 2013 4:23 am

Here's the section of the red-book where I got submit.jar:

4.2.2 Set up Ant FTP support in Eclipse
To facilitate the application deployment from the Eclipse workbench running on the workstation to z/OS, the Ant FTP support in Eclipse needs to be set up.
Download commons-net-1.4.1.zip and jakarta-oro-2.0.8.zip from:
http://jakarta.apache.org/site/download ... ns-net.cgi http://jakarta.apache.org/site/download ... ds_oro.cgi
Extract commons-net-1.4.1.jar and jakarta-oro-2.0.8.jar from the zip files and put them into a directory called c:\ant_ftp_jars.
Open Eclipse and select Window → Preferences → Ant → Runtime. Under the classpath tab, select Ant Home Entries and click Add External JARs. Pick those two jar files in the directory c:\ant_ftp_jars from the file selection dialog. Then click Open. The Ant FTP support jars have been added to the Ant classpath.
Now the Ant FTP can be used in a buildfile running in the Eclipse workbench.

Does this mean I have to go to Apache for support?

dovetail
Site Admin
Posts: 1856
Joined: Thu Jul 29, 2004 12:12 pm

Re: submit.jar not working right

Post by dovetail » Tue Mar 12, 2013 9:09 am

OK Earl, I finally figured out which red book you are referring to:

http://www.redbooks.ibm.com/abstracts/s ... .html?Open

In the additional materials:
ftp://www.redbooks.ibm.com/redbooks/SG247291

there is a "JZOS_Batch_Tool.zip" file that contains a submit.jar

This is not part of JZOS - it is apparently just a tool that one of the authors of the Redbook contributed.
We were not involved in this redbook; am not aware of a newer version of the "submit.jar".

You may try contacting one of the red book contributors.

Also, you may want to look at the IBM JZOS Cookbook, which is on developerWorks.
https://www.ibm.com/developerworks/comm ... 1f90169bd3

It is much more recent, and it includes some Eclipse Ant tooling for submitting jobs.
The best place for questions regarding JZOS is probably on the JZOS developerWorks forum.

Post Reply